Build & plugins failed

Hi, today all my failed…suddenly all the plugin can’t be used & generated error. For instance.

UserError: Error: CordovaError: Failed to fetch plugin cordova-plugin-device@~1.1.6 via registry. Probably this is either a connection problem, or plugin spec is incorrect. Check your connection and plugin name/version/URL. This could be caused by a problem with a different plugin.

Could you advice, thank you

Try removing some of the other plugins in your app as a test - it’s possible there is a conflict. Once the plugin which is causing the problem has been identified, you can look for a solution.