@havesource/cordova-plugin-push: Getting ":app:compileDebugKotlin FAILED" error

Hi Team,

We are using the Voltbuilder to build the android app. Currently, its failing while building the app.

When we checked logs on the Voltbuilder site to debug the issue, we found that the app failed with “:app:compileDebugKotlin FAILED” error. Details of the error as follows:

Runtime JAR files in the classpath should have the same version. These files were found in the classpath:
    /root/.gradle/caches/transforms-3/37c16254af6de93c45d2587b8dfcd992/transformed/jetified-kotlin-stdlib-jdk7-1.5.20.jar (version 1.5)
    /root/.gradle/caches/transforms-3/16f0fa7a8f147bbbdd08181b1d0ed2ab/transformed/jetified-kotlin-stdlib-1.7.10.jar (version 1.7)
    /root/.gradle/caches/transforms-3/727d189c560aae87eb38bbb136e543d5/transformed/jetified-kotlin-stdlib-common-1.7.10.jar (version 1.7)

I am sure that the issue is not from the our side because of the following things:

  • We have not changed anything recently in the code and the configs. Till recently, the app creation was happening properly, suddenly from yesterday we started to face the issue.
  • I don’t see the kotlin related config in the configuration files.

I have attached the following two files for your information:
1)voltbuilder.log file, to see what exactly issue got logged

2)Android config file, to see what configs we are passing to build app

I think there actually has been a change to your config file.

The last time your job built successfully was in back on Feb 17. At this time, you used this plugin:

  <plugin name="@havesource/cordova-plugin-push" source="npm" spec="^2.0.0" />

In your latest builds, you have

 <plugin name="@havesource/cordova-plugin-push" source="npm" spec="4.0.0-dev.0" />

(There may be other changes as well)

Hi ghenne,

Thanks for reply,

For android, We have changed @havesource/cordova-plugin-push to 4.0.0-dev.0 long time back, we have run build using this version many times and those were successful.

For ios, we are still using “^2.0.0” version, you might have compared last ios success build with current android build. Please compare last successful android build with current failed android build(whose logs I have attached)

Thanks and Regards

You’re right - I didn’t realize your iOS build uses a different config than for Android.

Are they both release or debug builds? I notice this:


> Task :app:compileReleaseKotlin


> Task :app:compileDebugKotlin FAILED

Hi ghenne,

We run it in the debug mode in the lower envs, that is, development, so that if any issue comes we can check it in the log. Whereas, we run it in the release mode in the upper envs, that is, production. So you might find some builds in debug mode and some in release mode depending on envs.

On 10th Feb 2023, we ran it in the debug mode in the lower envs, it was successful, I guess you can compare that log file with which I send you at start of the thread.

Just for your reference, Today I ran a build in release mode in the upper env, I am attaching its log, please have a look, it have failed with " Task :app:compileReleaseKotlin FAILED" error:

Thanks and Regards

We will have a look at this end.

The problem is likely related to one of your plugins. It would be good to figure out which one. Try removing plugins from your config.xml until you get a working project.

It looks like the problem is with @havesource/cordova-plugin-push.

Here is someone else with the same problem. It’s in the GitHub repo for the plugin. It does not seem to be a problem with VoltBuilder.

You might want to try the suggestions in the Github repo.

I had same problem, I solved as reported here: