Strange message after iOS Build migration to iOS 6.1 and Cordova 10

Hello,

we have recently started building on Cordova 10 with iOS 6.1. this is done by default with the cordova-plugin-wkwebview-engine plugin. We could and did not need to test it locally until now. Repeatedly we now receive a rejection from the Apple test team with these screenshots attached:


From which direction (plugin) does this error message come? One even mentions the term Android.

Does the wkwebview module not initialize correctly or could the error be somewhere else?

Thanks in advance and best
Greetings from Germany
Marcel

The message doesn’t look like anything VoltBuilder would generate - it does not make any changes to your runtime.

Are you able to reproduce this on an iOS device?

When I downgrade to iOS 5.1.1 it works fine. It seems that the plugin “cordova-plugin-wkwebview-engine” is not initialized correctly.

It must not be included in the config.xml for iOS 6.1, otherwise there will be an error message during build. When I look at the build log, does it seem not to be integrated otherwise?

Am I doing something wrong in the config.xml?
Must the setting <preference name="WKWebViewOnly" value="true" /> still be included?

Cordova has a good article on this:

https://cordova.apache.org/howto/2020/03/18/wkwebviewonly.html

The section in Future Roadmap has now implemented.