Android target 34

Any idear we we can build for version 34 ?

1 Like

Responding to follow this question.

I just tried submitting a new update targeting min SDK version 34
preference name=“android-targetSdkVersion” value=“34”
It went through the VoldBuild process fine and gave me an apk file. I created a new release in Google play console and I’m getting a message saying the app doesn’t adhere to Google Play Developer Program Policies. when I click on the “go to policy status” screen it’s telling me it doesn’t meet the minimum APK even though the release information shows Target SDK = 34.

I’m caught in an infinite loop it appears.

I also have another note which may or may not be relevant. It says “App Integrity, releases not signed by Google Play. Google Play’s integrity and signing services help you to ensure your apps and games are experienced the way you intend”. then there are links for “get integrity protection” and “Use play app signing”. I don’t know what either of these things are, or if they are required. Since I used the Volt signer tool to create the keys I don’t want to do anything to screw that up.

So I got past that screen. After scrolling way down on the screen I was finally able to see the Release notes section. I updated the notes and clicked the “next” arrow and was able to submit it for review. I suspect things will go OK from here on out.

I just want to confirm that we’ve had several reports that SDK 34 is working without issue. If you are running into problems please let us know.

Confirmed, my app was released last night and is working as expected.

Did you also set compileSdkVersion? I’m trying for this:

    <engine name="android" spec="13.0.0" />        
    <preference name="android-minSdkVersion" value="22"/>
    <preference name="android-targetSdkVersion" value="34"/>
    <preference name="android-compileSdkVersion" value="34" />

I am having this issue when I upload the build to Google Play Console with SDK 34.

com.google.android.play:core:1.8.3

Google Play Core (com.google.android.play:core) agregó esta nota para la versión del SDK 1.8.3:

Update your Play Core Maven dependency to an Android 14 compatible version! Your current Play Core library is incompatible with targetSdkVersion 34 (Android 14), which introduces a backwards-incompatible change to broadcast receivers to improve user security. As a reminder, from August 31, Google Play requires all new app releases to target Android 14. Update to the latest Play Core library version dependency to avoid app crashes: Google Play Core Library の概要  |  Android Developers

No, here is what I have:

<preference name="android-minSdkVersion" value="22"/>
<preference name="android-targetSdkVersion" value="34" />

This is likely from a plugin, or a problem in your config.xml. It may be worthwhile to start a new thread and post your config.xml.

My settings work (all the way), but I guess they are somewhat redundant.