App store error: ITMS-90338: Non-public API usage

I’m trying to build a new version of an app for iOS, and I’m getting this error in an email from Apple:

ITMS-90338: Non-public API usage - The app references non-public selectors in (app name): applicationNameForUserAgent, initWithFrame:configuration:, isMainFrame, navigationDelegate, navigationType, setNavigationDelegate:, setProcessPool:, targetFrame, userContentController. If method names in your source code match the private Apple APIs listed above, altering your method names will help prevent this app from being flagged in future submissions. In addition, note that one or more of the above APIs may be located in a static library that was included with your app. If so, they must be removed. For further information, visit the Technical Support Information at Requesting Technical Support - Support - Apple Developer

The app I’m trying to build is a minor bug fix to an app I’ve already built successfully and released on the app store, and I’ve never seen this error when building it before. I last successfully built the app on 27 May, so could a change made since then have caused this issue?

Could you give it another try and let me know what you see? We are rolling out some upgrades to our infrastructure, but it shouldn’t cause an issue like this.

I just tried again and got the same error.

This build definitely was done using our older infrastructure. I suspect that with WWDC happening today Apple may have changed some standards. We’ll look into this, but you may want to do the same. I’ll let you know what we find.

Thanks for looking into it!

It looks like some other developers are having this problem with Cordova-built apps today, so it may be due to something Apple has changed recently. https://developer.apple.com/forums/thread/707350

None of the method names listed in the error message appear in my HTML file (I double-checked) so I don’t know what else I can try on my end.

I see this report in the thread you referenced:

Message from Apple: “The issue has been resolved on the app validation backend. Please try resubmitting. Sorry for the trouble.”

Can you try submitting again?

I submitted again and it worked, thanks for looking into this.

I spent over 6 hours trying to solve this problem, until I found that thread on developer.apple.com that showed that hundreds of other people were having the same problem. Apple fixed it the next morning… but jeeze, Apple, can I have those 6 hours of my life back, please? I’ll take a new iphone 14 instead.