Builds queueing forever (again)

Today (7/19) Android builds are queueing forever - same as yesterday. Submitted a build 30 minutes ago and it is still showing ‘queueing’. Have refreshed page, logged out and back in, etc.

I’m looking into this right now, but I believe this may have been a one time issue. Can you resubmit the build?

We had a brief outage due to our upstream provider at 12:50PM EDT lasting 2-3 minutes. Unfortunately it appears that your job was caught in this outage. Here’s what we’re doing to make sure this doesn’t happen again:

  1. Transitioning some infrastructure away from the upstream provider that’s been the root of these issues.
  2. I’m improving our infrastructure to be more resilient to brief outages such as this.

Please let me know if your job is now completing successfully.

It does seem to be working ok now. Thanks for replying and working to improve the situation.

We and with that our customers are also experiencing this infinite queueing now pretty often.
Actually a build started around 90 minutes ago and is still queueing.
Status API response is: “{“status”:“Queueing”,“timestamp”:1658387048}”

So stabilization of the infrastructure would be very much appreciated.

What happens if you do a refresh? Sometimes (rarely) it seems the job actually builds, but the progress API does not update properly.

We are actively looking how this could happen.

@jeugro, can you give us any more info about when this happened to you? We’re looking at the logs now. The job number would be good to have as well.

I see an event at 02:11 EST this morning. Could that have been you?

Android Build is taking hours now in the Queuing stage

What happens if you do a refresh? Just tried a job here - it ran immediately.

Works now, was stuck in the morning

Same time Queuing again for more than 15 Minutes, i’m trying the IOS

Really frustrating …

I agree - we’re seeing some slow performance in one of the date centers we are using and are working with the vendor.

I just submitted an iOS job here - it processed correctly. Try submitting it again.

I’m not sure if this is related or not, But this happens when i submit with the API, once i resubmit manually it works

Hopefully this can be solved soon because this is a core component in my business

Using the API should not make a difference - but please send as more data if you can.