Can't build ios with cordova-plugin-firebasex

Hi,

Whenever i add the plugin

<plugin name="cordova-plugin-firebasex" spec="16.4.0" />

with or without variables, the build time fails and voltbuild says build took too long to respond and it timesout

Can you please help ?

I tried to increase the deployment-target for ios platform to 12.0.0 or even 17 and I’m getting this error

UserError:
ld: symbol(s) not found for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Can you attempt with the latest version 16.5.0. If it times out, please respond and we’ll review the log.

Hi. I have same problem with <plugin name="cordova-plugin-firebasex" spec="16.5.0-cli">
I have these errors:
UserError: Command took too long to execute:
Command ‘[‘cordova’, ‘build’, ‘ios’, ‘–device’, ‘–release’]’ timed out after 600 seconds

I have no problem with 16.1.0-cli

Thanks for the support!

Same issue happens with 16.5.0

Here are the logs: https://apps.volt.build/ae1a9a3d-22a2-4f84-b26d-e99299a24fe8/voltbuilder.log

Any reply on this?

Please give it another try - we’re working to speed up this process but have temporarily increased timeouts.

It is processing for more than an hour till now

We will continue to optimize this, I suspect that the job timed out.

It works now

Thank you