CocoaPods could not find compatible versions for pod OneSignalXCFramework

My iOS build was fine until yesterday when I started getting the following during my online build process:

UserError: [!] CocoaPods could not find compatible versions for pod “OneSignalXCFramework”: In Podfile: OneSignalXCFramework (= 3.10.1) Check your log file for more information.

Because I haven’t changed anything major in my app, I assume the issue is on the build side?
Please let me know if I need to fiddle with settings in my config to fix it.

I’ve been using the OneSignal plugin for a while now:
plugin name=“onesignal-cordova-plugin”/>

Here are all my plugins:

  plugin name="cordova-plugin-statusbar" />
  plugin name="cordova-plugin-splashscreen" />
  plugin name="cordova-plugin-inappbrowser"/>
  plugin name="cordova-plugin-network-information"/>
  plugin name="cordova-plugin-appversion"/>
  plugin name="cordova-plugin-device"/>
  plugin name="cordova-plugin-x-socialsharing"/>  
  plugin name="onesignal-cordova-plugin"/>

Since you’re not pinning your plugins to a specific version, VoltBuilder will use the latest version of the plugin.

I’ll bet one of your plugins has been recently updated and is now incompatible with your other plugins.

By specifying the version of each plugin you want to use, you can avoid this problem:

<plugin name="cordova-plugin-device" spec="^1.1.0" />

The fix:
<plugin name="onesignal-cordova-plugin" spec="3.0.1" />

Thank you for the suggestion - there was an update to 3.0.2 about 3 days ago which is not working on voltbuilder at the moment.

It probably doesn’t have anything to do with VoltBuilder itself - it’s probably a dependancy on another plugin which isn’t ready for 3.0.2.

Some tips for people who have similar issues:

  1. Get your project up to date by using Cordova 11. You’ll be using the latest tools.
  2. Pin your plugins to specific versions by adding clauses like spec="3.0.1" to your <plugin statements in config.xml.
  3. Use npm to check what the latest versions are for plugins.