Cordova File Plugin Error

UserError: CordovaError: Version of installed plugin: “cordova-plugin-file@6.0.2” does not satisfy dependency plugin requirement “cordova-plugin-file@^4.0.0”. Try --force to use installed plugin as dependency.

Cant compile

Check through your plugins and make sure you’re using up to date versions.

For example, you’re using a very old version of this plugin:

<plugin name="cordova-plugin-file" source="npm" spec="~4.1.1" />

The current version is 6.0.2, released 2 years ago.

I am using latest one only

What’s in your config.xml?

<gap:plugin name=“cordova-plugin-whitelist” source=“npm” />
<gap:plugin name=“cordova-plugin-camera” source=“npm” version=“4.0.3” />
<gap:plugin name=“cordova-plugin-inappbrowser” source=“npm” />
<gap:plugin name=“cordova-plugin-background-mode” source=“npm” />

<gap:plugin name=“cordova-plugin-geolocation” source=“npm” />