Difference between debug and release builds


I am currently facing an issue with a Neptune (P8 6.0.14) build for Android. This build is for our local server which has an invalid certificate (not the Android certificate).
With the release build I am stuck at the logon screen in the Neptune app whereas with the debug build I am able to enter my credentials and continue to the startpage. Are there any checks in the release build that are not done in the debug build? I have done the debug built to analyze where the issue is with the app stuck at the logon screen but the debug app build works so it’s difficult to analyze.

Please excuse me if I am not explaining everything perfectly - I am fairly new with this.
Regards, Christian

The first thing I would look at is the Android Keystore. How is that being made? Are you sure it’s good?

Well, the Android keystore shouldn’t be the problem as I am using the same for a build that is used for external connections. The problem only occurs with the local server url.
Are there any checks/steps done differently in a release build compared to a debug build?

I’m not sure I understand what you’re seeing. It’s unlikely, however, that it is the result of VoltBuilder.

Can you add some debugging to help pinpoint the problem?

Hi, had the same issue with stuck in logon screen. Ticking Allow HTTP Cleartext Traffic (Android) in Neptune P8 Mobile connection part solved the issue.



Hi Christian,

Have you tried the remote debugging tool available in the Neptune P8 Cockpit while using the signed APK ?

I guess you are using the SAP Authentication with a Pin Code ?

FYI, We are in P8 6.0.15. APK are build using Cordova CLI for signed and debug, and I do not have the issue you described. I also tested signed APK built in Volt just to make sure it does not come from there.

While we were in SP14 we had issue with logon on APK with debug apk (I do not think I tried with signed), it was impossible to logon something connection refused I should check with an old APK. Moving to SP15 solved the issue. We are only using https (no cleartext traffic option enabled) and certificate is trusted by CA recognized by browser.

Hope this will help.


Good Morning.
Thanks for all your responses.
@Mats: You are right. I ticked the “Allow HTTP Cleartext Traffic (Android)” checkbox in Neptune and now it works. We are using http. https would be available as well but with an invalid certificate.

I have tried the remote debugging and ADB but those didn’t show any erros as the app was stuck at the logon screen.

Once again, thanks for your responses.
Regards, Christian