Error in Uploading to Apple store

ServerError: upload_to_itunes failed An error (-10814) occurred. The operation couldn’t be completed. (OSStatus error -10814.) (null)

please resolve this issue


We’re on it.

Over the weekend, we updated to Xcode 14 (for iOS 16 support). That broke the upload code.

We are working on a fix right now.

Any word on this? I’m getting the same error and can’t upload to the app store.



The fix is in final testing now - if all goes will, it will be up in the next few hours.

We apolgize for the inconvenience - there was nothing in Apple’s release notes about this, so we dropped everything to get it fixed.

This issue should be resolved. Please let us know if you continue to have issues uploading.

There may still be a problem with this - we’re on it.

I think we’ve got it - please submit your jobs again.

There is a new requirement. If you get this error message:

UserError: ERROR: Cannot obtain the content provider public id. Please specify a provider short name using the -asc_provider option.

You need to add a parameter to your voltbuilder.json file, which will look like this:

"itunesShortName": "NSBASICCorporation",

An iTunes account may be used to create apps for more than one company, or “provider”. Apple gives each of these a Short Name. It’s not always easy to find the short name for a provider, so we’ve added some output to the log to help find this.

Provider listing:
   - Long Name -                                 - Short Name -
1  DATA IMAGES INC                               Y9UDR9XXXX
2  XXXX Software GmbH                            G6AV52UXXX
3  Danish Farm Computers Ltd.                    G7M2XN7XXX
5  NS BASIC Corporation                          NSBASICCorporation
6  ghenne|11145618|1                             ghenne111456XXX

I applied the provider name, but now I get this error:

UserError: ERROR: The username (my itunes email account) is not a member of the provider NSBASICCorporation. Contact your team admin for assistance. (1296)

Do I need use more tags in my voltbuilder.json to inform this data?

Thank you

Are you using NSBASICCorporation as your Short Name? That won’t work - it belongs to us.

Have a look at your output log. You’ll see the Provider listing there.

Sorry, now I understand and find the information at output log on Volt.

Solved for me