Error when building: not a valid version number

I would appreciate too much if someone could help me.
Until yesterday I could build without problem and today I wanted to build again and I mark this error:
“UserError: Error ‘Plugin-Version’ of ‘unspecified’ for ‘com.android.build.gradle.AppPlugin@985ec37’ is not a valid version number You most likely have an out of date plugin or a plugin conflict.”

I already changed the plugins “onesignal-cordova-plugin” and “cordova-background-geolocation-plugin” to AndroidX but still getting the error.

Does the problem happen when using one of the plugins, or just with both?

In this case I’m using both plugins. But I already did the test individually and it keeps getting the same error.

The next step is to isolate the problem. Build twice, each time without one of the two plugins. Do they both have problems?

(This is not likely to be a VoltBuilder issue. It’s something to do with the plugins you are using. Have you checked for open issues in their GitHub repositories?)

I have already done the test and the plugin that marks the error is “onesignal-cordova-plugin”.
Don’t you know something about this plugin?

It’s come up several times here before - the latest just a few days ago. Use the search function on the board to see:

https://voltbuilder.discoursehosting.net/search?q=onesignal%20order:latest

FYI: This is new for me as well… now happening with onesignal 3.0.0 and 3.0.1 :frowning:

Also, if you look at my build logs it appears everything built just fine, but Volt still rejects it due to this error. According to a forum post I found online, this is not a game stopper error and can be safely ignored.

https://github.com/OneSignal/OneSignal-Cordova-SDK/issues/709 <–scroll way to the bottom

Additional note: I can confirm this same “error” is produced with my local builds (my own build enviroment). However, the app indeeds builds just fine and onesignal works perfectly.

Volt: Anyway the Volt android build system can be modified to ignore this error so we can successfully build/publish android? Especially if the build is successful (see below)

Another update: Odd thing is Volt built my app just fine about 3 days ago. Trying to target same Onesignal, cordova, sdk, etc versions.

BUILD SUCCESSFUL in 30s
55 actionable tasks: 55 executed
Built the following bundle(s):
/platforms/android/app/build/outputs/bundle/release/app-release.aab

Error ‘Plugin-Version’ of ‘unspecified’ for ‘com.android.build.gradle.AppPlugin@1bc85003’ is not a valid version number
You most likely have an out of date plugin or a plugin conflict.
Build 9127d15b-f630-4ee2-a8ea-70519427312a failed

Posting again just incase Volt team didn’t see my (many) edits. Is or will it be possible for Volt to ignore this non-fatal error message?

Thank you for the information. We’re working on a fix now.

The fix is being reviewed now.

Thank you!

OK, give it another try. We’ve just updated the servers.

I think while you were figuring this out, the latest version/build I tried got uploaded to Google Play. No problem there, but I currently have no update to push out. I might by the end of the day and will let you know when I do.

Thanks for addressing this!

The solution they are mentioning is about the bug with the plugin “onesignal-cordova-plugin”?
Because if so, I just tried it now and it continues to show the same error.
I would appreciate that in case that error has been fixed, you will help me with the configuration of the “config.xml” file.

@desarrollo - What version of onesignal are you using? I 'm no expert in onesignal, but I think you need to be on 3.0.1.

I was trying with version “2.7.0” but now I tried with version “3.0.1” and it keeps showing the same error.

→ plugin name = “onesignal-cordova-plugin” spec = “3.0.1”

It would help if you showed the exact error.

in Volt I get the following error:

Failed UserError: Error ‘Plugin-Version’ of ‘unspecified’ for ‘com.android.build.gradle.AppPlugin@668a086b’ is not a valid version number You most likely have an out of date plugin or a plugin conflict.

and this is the log that shows me: https://apps.volt.build/b1985aad-8cf3-41a1-b9ac-5dd228cd68dc/voltbuilder.log

Should be OK now - give it another try!