Error while building iOs Version

Hey all!

I’m getting the following error while building the Ios version of my app (Android version works fine). Haven’t changed anything (neither a plugin or anything else) from a month ago, and it worked just fine then. Here is the log:

The following build commands failed:
CompileC /Users/voltbuilder/Library/Developer/Xcode/DerivedData/VTPortal-bgvvkrlpvtocsygllspstetcwtxy/Build/Intermediates.noindex/ArchiveIntermediates/VTPortal/IntermediateBuildFilesPath/VTPortal.build/Release-iphoneos/VTPortal.build/Objects-normal/arm64/NfcPlugin.o /platforms/ios/VTPortal/Plugins/phonegap-nfc/NfcPlugin.m normal arm64 objective-c com.apple.compilers.llvm.clang.1_0.compiler
(1 failure)
Command finished with error code 65: xcodebuild -workspace,VTPortal.xcworkspace,-scheme,VTPortal,-configuration,Release,-destination,generic/platform=iOS,-archivePath,VTPortal.xcarchive,archive,CONFIGURATION_BUILD_DIR=/platforms/ios/build/device,SHARED_PRECOMPS_DIR=/platforms/ios/build/sharedpch,EMBEDDED_CONTENT_CONTAINS_SWIFT = YES,ALWAYS_EMBED_SWIFT_STANDARD_LIBRARIES=NO,LD_RUNPATH_SEARCH_PATHS = “@executable_path/Frameworks”
xcodebuild: Command failed with exit code 65
Error: xcodebuild: Command failed with exit code 65
at ChildProcess.whenDone (/node_modules/cordova-common/src/superspawn.js:136:25)
at ChildProcess.emit (events.js:315:20)
at maybeClose (internal/child_process.js:1048:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:288:5)

Conflict found, edit-config changes from config.xml will overwrite plugin.xml changes.
To figure out which edit-config clause is the problem,
remove edit-config clauses from config.xml one at a time and rerun.
reset_keychain
Output:
Build a0493eb6-5cab-435a-8d7a-7ac7b3ed60c9 failed

And here is the config.xml. I already tried to submit the config without any edit-config, and I’m getting the same error:

Have you checked if all your plugins are up to date (or not deprecated)?

It seems that the NFC Plugin isn’t working with XCode 12.5. There was a commit that fixed the issue that hasn’t been merged into the npm yet, according to: https://github.com/chariotsolutions/phonegap-nfc/pull/451
This is the working branch: https://github.com/Simbioz/phonegap-nfc
Would it be possible for you to fix this? Or maybe a way to include our own plugins into the zip?

1 Like

That sounds like something best fixed by the maintainers of the plugin. Have you contacted them?

We require plugins to have npm entries. If you want to use a custom plugin, please contact us about getting an Enterprise Plan.