@havesource/cordova-plugin-push - App not opening when click on push

I am using the plugin: @havesource/cordova-plugin-push

App not opening when click on push.

This happens on mobiles with Android 12 and Android 13.

My android-targetSdkVersion in the config.xml is 31.

Tested plugin version: 3.0.1 and 4.0.0-dev.0

I would like to know if someone else works correctly under the same conditions as me, so I can know if the problem is in the plugin itself or in my code.

My JS Code:

document.addEventListener('deviceready', onDeviceReady, false);
document.addEventListener('resume', onDeviceReady, false);

function onDeviceReady() {

	const push = PushNotification.init({
		android: {
		ios: {
			alert: "true",
			badge: "true",
			sound: "true",
			clearBadge: "true"
	push.on('registration', (data) => {
		document.getElementById("regId").value = data.registrationId;
	push.on('notification', (data) => {
	push.on('error', (e) => {
		// e.message
	document.addEventListener("backbutton", onBackKeyDown, false);
	// Cordova is now initialized. Have fun!
	console.log('Running cordova-' + cordova.platformId + '@' + cordova.version);

I’ve never used this plugin myself - but have you tried remote debugging to see if there are any errors on the console?

Maybe that, otherwise I’d raise an issue in their github.

Thanks for the help.

I have already been able to solve it by modifying the payload:

$message = array(
	'title'	=> $nombreCole,
	'body' => $message,
	'icon'	=> 'fcm_push_icon',
	'color'	=> $color,
	'badge'	=> '1',
	'sound'	=> 'default'
	//'click_action' => 'FCM_PLUGIN_ACTIVITY'

Simply commenting out the ‘click_action’ already works!

Tip : If you’re pasting code, html or config files, surround the code with triple back ticks (```), before the first line and after the last one. It will be formatted properly. (We fixed it for you this time)