I need help with the config.xml

Hey, I have been trying to upload my .zip file multiple times and at first, the file is accepted but then I receive a message saying that it failed ‘UserError: Parse Error in config.xml: no element found: line 12, column 54’ (sometimes the line & column vary), I will try to attach my config.xml file below, can someone help me fix it so that it works? Thanks anyway.

<? xml version="1.0" encoding="UTF-8" ?>
<widget xmlns="https://www.w3.org/ns/widgets" id="com.GeorgioSaidy.The5plets" versionCode="1" version="1.0.0">
<name>The 5plets</name>
<Description>The 5plets App has come to life. Expect updates soon.</description>
<author>Georgio Saidy</author>
<preference name="orientation" value="portrait"/>

Tip : If you’re pasting code, html or config files, surround the code with triple back ticks (```), before the first line and after the last one. It will be formatted properly. (We fixed it for you this time)

Please repost your config.xml, with the formatting tip.

Just did, thanks for the tip

Thanks! Could you run your job again? I’ll watch for it in the logs.

Follow up - The last job you ran seems to have worked. Did you find the problem?

Hey, sorry for the delayed response. The project I ran did indeed work and I was even able to make an update. However that was only after I reported the problem and got a response and I still haven’t figured out what was wrong, it just worked then. Now, I am trying to make a new update and it gives me the following error (after it had already stated that it was accepted too):
UserError: Parse Error in config.xml: mismatched tag: line 12, column 2
I ran some changes to the config.xml file: I added an <icon src="#"> tag and removed the author name leaving it a <author email="#" /> and changed the id in the <widget> tag (also, I changed the version to 0.0.1 as I’m still testing the app, don’t know if that matters though)

There’s a formatting problem in your config.xml file.

You have a <platform name="android"> tag, but no closing </platform> tag.

Here’s a handy utility to check the formatting of your config.xml.

Thank you so much, it worked! And thanks for the tip.