Inexplicable errors with recent builds

My distribution certificate for iOS was about to expire so I generated a new one and updated the provision files for my four current apps. However, on submitting two of these these apps to VoltBuilder, I got some inexplicable errors.

  1. LR-Sel

I originally submitted this app for a built having forgotten to update the version number. Now, whatever I change in config.xml, I get the error that this version has already been submitted to App Store Connect. The original version number was 1.0.0. I then updated it to 1.0.1, then to 1.0.2, then to 1.1.0 but all failed with the same error. Here is the current line from config.xml:

<widget id="com.lion-ridge.LR-Sel" ios-CFBundleVersion="3" version="1.1.0"

Here’s screen print of the directory showing that I’ve recreated the file:

Is it possible that there is a cached version of stuck in the system that is continually being submitted rather than the new version that’s just been created?

  1. LR-Sat

This is even stranger. This app was accepted and posted to the App Store just a few weeks ago. I’ve not changed anything except the distribution certificate and the provision file and updated volt builder.json to match, and updated the version number in config.xml.

However, I am now receiving the error

Here is a screen shot of the relevant part of the directory structure of the app:

Screenshot 2022-12-12 at 17.20.12

and here is the relevant portion of config.xml:

    <platform name="ios">
        <!--<preference name="WKWebViewOnly" value="true" />
        <feature name="CDVWKWebViewEngine">
            <param name="ios-package" value="CDVWKWebViewEngine" />
        <preference name="CordovaWebViewEngine" value="CDVWKWebViewEngine" />-->
        <preference name="scheme" value="app" />
        <preference name="hostname" value="localhost" />        
    <preference name="target-device" value="handset" />
        <icon height="20" src="icons/Icon20x20.png" width="20" />
        <icon height="40" src="icons/Icon40x40.png" width="40" />
        <icon height="180" src="icons/Icon180x180.png" width="180" />
        <icon height="80" src="icons/Logo_80x80.png" width="80" />
        <icon height="120" src="icons/Icon120x120.png" width="120" />
        <icon height="1024" src="icons/Logo_1024x1024.png" width="1024" />
        <splash height="2436" src="icons/SplashScreen1125x2436.png" width="1125" />

Any ideas?

  1. You need to update CFBundleVersion every time you upload a new build to apple. Version only needs to be changed when you finally submit a build for review.

  2. You either need to move the icons out of the www folder or change src to equal: www/icons/…

Thanks, Jeremy, those suggestions have worked. They must be a tightening up with the new Apple software because I don’t recall having to do them before. The bizarre thing is that one app processed without having to change the pointer to the icons, whereas the other didn’t.

Anyway, your help is much appreciated

Nothing has changed with the CFBundleVersion vs Version thing in forever (if ever). My practice on that is to just keep them always the same. Some people only update version after a successful publish to the store.

The only thing I can think of on the icons is maybe you had a duplicate folder in the root of your project and since deleted it. Otherwise, that config should never have worked, but who knows :).

I must say I can’t remember having to change CFBundleVersion before, but that might just be Alzheimers creeping in. Regarding the other issue, I’ve compared my two apps and you are absolutely correct. The one that didn’t require a change had a copy of the icons folder in the project root. I’m still baffled how the other project ever worked, but that’s water under the bridge now that I understand these two issues.

Many thanks for your patience and your help, much appreciated