iOS Build Error -24169

Hi all,

today we’re getting this error building app for iOS:

UserError: ERROR: Error Description not available (-24169)


Build log:

(we use build + upload to AppStore Connect)

iOS past days builds went fine.
Today Android’s build went fine.

What does this error mean?


Looking at the build logs, this message is being returned by Apple:

[2023-02-17 06:21:11 EST] <main>  INFO: id = 20230217062111-516
[2023-02-17 06:21:11 EST] <main> DEBUG: SMART-CLIENT: getCurrent(); current data center is null
[2023-02-17 06:21:11 EST] <main> DEBUG: SMART-CLIENT: getCurrent(); iterator was null, setting it
[2023-02-17 06:21:11 EST] <main> DEBUG: SMART-CLIENT: getCurrent(); setting current data center to:
[2023-02-17 06:21:11 EST] <main>  INFO: iTMSTransporter Correlation Key: 630d8be1-bd2b-4254-8943-8294e083a2b8-0001
[2023-02-17 06:21:11 EST] <main> DEBUG: SMART-CLIENT: Host HTTP header:
[2023-02-17 06:21:12 EST] <main> ERROR: Error Description not available (-24169)
[2023-02-17 06:21:12 EST] <main> DBG-X: Returning 1

We haven’t seen this error before - has something changed in your listing in iTunes Connect?

I’m getting the same error this morning. Yesterday builds uploaded to Appstoreconnect with no issues. To the best of my knowledge nothing changed on my end. Certificates & profiles all up to date.

build log:

I’m building from AppStudio.

Fairly urgent to get this resolved :slightly_smiling_face:



The error is happening at Apple’s end, not ours. The problem may be out of our control.

Let’s see if the problem in our build or in the upload.

To do so, can you try the following?

  • In voltbuilder.json, remove the itunesAccount, itunesAppPassword and itunesShortName lines.
  • Do another build. It should complete normally.
  • Download the ipa to your system
  • Upload to iTunes directly.

Let me know if you have any questions!

nothing seems changed in our end.
Certificates & Profiles are valid (expiring in May 2023).


Followed those instruction and uploading directly to iTunes directly worked fine.

I can send you Apple’s log if that would be helpful…

We can reproduce the problem here.

It looks like something changed at Apple’s end. We are working on a fix now.

Thanks, @Nate. That’s the workaround for now, until we can get our upload mechanism going with whatever Apple changed at their end.

Never a dull moment here!

Tried just now to build iOS and went fine! (and successfully uploaded to Apple servers)


…it just wants me to appreciate how nice it is to upload directly from AppStudio :slight_smile: