iOS problem: "Cannot obtain the content provider public id". cordova-plugin-firebasex


Today we are unable to upload our IOS app. We are using the same voltbuilder.json file as we did last time, but now it says it cannot obtain the provider public and no “Provider listing” in the log is to be found, as mentioned in the Docs section. The “itunesShortName” parameter is included in the file.

Package Summary:
1 package(s) were not uploaded because they had problems:
/ - Error Messages:
Cannot obtain the content provider public id. Please specify a provider short name using the -asc_provider option.
[2022-11-10 06:13:20 EST] DBG-X: Returning 1

Thanks in advance!

This is due to a new requirement by Apple.

It is covered here.

As stated in the original comment, the “itunesShortName” is included in our voltbuilder.json file. And the is no longer providing the “Provider listing” section in the logs. It did a few weeks ago, but not anymore.

Ah! You’re using the Xcode 13 server. It doesn’t have the enhancement to pass that through to iTunes yet.

It needs to be back ported. We are planning to do so tonight.

Glad to hear that! Thanks for the information of what was happening. We will deploy our application tomorrow then :slight_smile:
Thanks again!

Still getting the same error. Did you implemented the enhancement on Xcode 13 yet?

Looks like your job is working now - all good?

Nopes, still getting the same error when building on XCode 13 (works fine on XCode 14 tho), which we need because of Push Notification plugin usage.

We’re working to get this done as quickly as possible.

1 Like

We’re hoping to have this in place by 12:00pm our time (EST).

The fix is place. Can you give it another try?

Still not working. Different error now. Can you take a look at the logs of the last deploy?

Here is the error you are getting:

ERROR: Upload is not in processing state, please try again. state: class Build 

Is your iTunes account ready for the upload?

It should, as it is working when uploading it on XCode 14.

I was afraid of that.

At the same time Xcode 14 came out, they replaced the upload utility. It looks like the old one does not work anymore.

What really needs to be fixed is cordova-plugin-firebasex. We’ll add some more information to the issue there this weekend. Hopefully, the maintainer is working on something. Have you looked to see if another plugin might work?

Good news here. For some reason, cordova-plugin-firebasex seems to be working now on XCode 14 using 12.1.0-cli version. I’m testing it now and I’m recieving push notifications, contrary to what was happening a couple weeks ago.

<plugin name="cordova-plugin-firebasex" spec="12.1.0-cli">

That’s great news.

I’ll ask the others with the issue to try the same.


no luck here. I have tried, building goes well but I am not receiving push notifications. Can you put your config.xml here?