[iOS] UserError: ERROR: Upload is not in processing state, please try again

Hi guys,

This is the first time I made an apple ios app, well actually I can’t say this an app app, because the content is honestly just a launcher to my web platform. I’ve built the Android version successfully, both debug and release, now it’s available on Google Play (Thanks to Volt Builder). Now I have a problem when I build ios for release/distribution, previously I have successfully build ios for development which generate ipa file.

It always said:

ERROR: Upload is not in processing state, please try again

I don’t why this happen, I believe that my credentials are correct (iosDistP12, iosDistP12Password, iosDistribution, itunesAccount, itunesAppPassword, itunesShortName)

Is there another way to upload an IPA file to the app store? Like when we uploading aab file to play store? Because I don’t have an apple device.

Thanks in advance


I searched this forum and someone already asked

His solution is to downgrade firebasex
<plugin name="cordova-plugin-firebasex" spec="12.1.0-cli">

But I tried it still failed, and I tried to change the spec to the latest and then its worked without error
<plugin name="cordova-plugin-firebasex" spec="latest">

Now my iOS app has uploaded to Apple Store Connect and processing on Testflight, I don’t know the next step to publish the app (still figuring out)

Glad to hear you solved it!

We’ve seen a lot of instability with uploads to the iOS App Store - it’s possible that you might have run into an outage. I’d be very interested to know if downgrading firebasex causes the error to occur reliably.

One other tip - if you always want to latest version of a plugin, you can remove the spec entirely.