Not able to build in Windows with error "keytool not found. Gradle not found."

Android and iOS build work fine but i am seeing following issue when trying to build Windows app (debug & release)::

keytool not found.
Gradle not found.

Please help.

I suspect you have the platform set to android in your voltbuilder.json. For iOS and Android, this is ignored, but for Windows it’s not. Please try setting the platform to windows and see if that works for you.

I removed all iOS and Android references but the error is the same. So I tried to compile the “hello world” cordova sample but the result is the same.
Maybe there is something wrong with my “Indy” plan?

Log files:
VoltBuilder run started at 2022-12-09 21:03:15.112208
Plan: Indy
Preflight Check
keytool not found.
Gradle not found.
Build 066fe56f-9cfd-40fe-aef0-62b282229b91 failed

voltbuilder.json file:
“verbose”: true,
“release”: “debug”


<?xml version='1.0' encoding='utf-8'?> My Project My Project is an app.

What am I doing wrong?

I’ll review your build and get back to you shortly.

I see the issue. Windows support is a bit different than our other platforms. You will need to add the following line to your voltbuilder.json:

"platform": "windows"

This solved my issue. Thanks!