***SOLVED *** Config.xml file not found

I’m trying to migrating from phonegap build to your service. I get “config.xml file not found” error when I try to build it. My config.xml is placed everywhere just to make sure it at the right location. xxx

I had a look at your most recent zip file. It doesn’t have the structure you think.

At the top level, you have a www folder. Your config.xml and other files are inside that folder. Have another look at the structure here:

What do you mean you look at my recent zip file? You mean you look at the zip files I uploaded? The recent one was me trying every way to get it to work. I have uploaded more than 10 times with the correct structure and not correct structure to try to debug the problem. I also place the config.xml files everywhere just to see I might get lucky. No matter where I put the config file, either in andriod or ios, it give me that error. There are other people on this forum that have the same problem. I think its your end that is the problem.

Also isn’t that a security breach that you can see my uploaded zip files? My passwords and everything is in there.

Make a sample zip file set up in a way you think is correct. Upload it. If it gets the same error again, let us know. We’ll have a look and see what the problem is.

(We have to keep projects which which fail around for a short time so the problem can be resolved - otherwise, we would never to able tell you what went wrong)

I have upload a zip file call sampletest in ios , I have taken out the file in certificates folder and nothing in voltbuilder.js , the config.xml is place at the root along with the voltbuilder.js, www, certificates folder. It still give me the error. That zip upload fine in phonegap build. Also thanks for your respond.

I wonder if it because I’m using windows 7 and zip it with winrar. I’ll try doing it with 7-zip and see if there still an error

OK, I see what’s wrong. You are zipping up your sampletest folder. You should be zipping just the contents of the folder.

Thats does fixed the problem, thanks!! you should address that to other people on your forum that have the same problem. Thanks!!!

**SOLVED ** To anyone who have the same problem and reading this, I suppose to highlight all the stuff inside my project folder ( config.xml, www, certificates etc.) then right click and zip it. Not zipping the project folder.