Some newbie questions

First of all, thanks for giving us a properly supported alternative to phonegap build! I have been tearing my hair out for the past six months trying to overcome the latest Apple changes.
Now a general question about plugin specs in config.xml. For my builds to work in phonegap build, I had to specify particular version numbers for each plugin. Ideally I just want to use the most recent. Can I drop the spec fields?
Also, there are two plugins that I use that are not on your list:

  1. com.phonegap.plugins.barcodescanner spec https://github.com/Telerik-Verified-Plugins/BarcodeScanner.git#6.0.5
  2. com.telerik.cordovaPlatformSpecificFiles spec https://github.com/Icenium/cordova-platform-specific-files
    Not sure if I actually need the second one, but my code specifically uses that particular bar code scanner so I’m sure I need the first one

Thanks for the kind words!

Yes, if you leave the spec part out of your plugin statement in config.xml, the latest version of the plugin is used. You can see the version number by looking up the plugin in npm, or by looking at the log which VoltBuilder outputs.

com.phonegap.plugins.barcodescanner looks good and should be available shortly (today). Looking it up in npm, it hasn’t been updated in 3 years and had only 14 users last week. Other barcode plugins seem to have replaced it.

cordova-platform-specific-files (I think that’s the proper name) also hasn’t been updated in 3 years. It isn’t listed in npm, so you probably want to find a better way to do this.

Thanks for the prompt response. I don’t know what the second plugin does, so I’ll take it out and see what breaks. I’ll look into more up to date barcode scanners but thanks for including the Telerik one, which allow me to get up and running with VoltBuilder and then sort the barcode scanner out at leisure

com.phonegap.plugins.barcodescanner is now available for use.

Thanks, much appreciated