UserError: Error: CordovaError: Failed to fetch plugin cordova

Keep taking out the plugins but so far keep getting same error

UserError: Error: CordovaError: Failed to fetch plugin cordova****

ALL was working 100% a few days ago, nothing has changed in the app at all.

Been testing for days now and always the same.

If you look at the first one that will not work

plugin name=“cordova-plugin-splashscreen”

NPM says downloaded last week 58,353

Also tested on Apps that was 100% working a few weeks back, same zip file changed nothing, and that also no longer works, so something must have changes else where.

Hope someone can help…

What’s the complete error message?

from the log the error message is (and is same for ALL plugins, looking at the LOG they ALL failed) Here is part of it…

Also tested with a few changes non work,
plugin name=“cordova-plugin-statusbar” source=“npm” spec=“2.4.3”
plugin name=“cordova-plugin-statusbar” source=“npm” spec="~2.4.3"
plugin name=“cordova-plugin-statusbar”

Discovered plugin “cordova-plugin-statusbar”. Adding it to the project
No scripts found for hook “before_plugin_add”.
Calling plugman.fetch on plugin “cordova-plugin-statusbar@2.4.3”
fetch: Installing cordova-plugin-statusbar@2.4.3 to
Running command: npm install cordova-plugin-statusbar@2.4.3 --save-dev
Command finished with error code 1: npm install,cordova-plugin-statusbar@2.4.3,–save-dev
Failed to restore plugin “cordova-plugin-statusbar”. You might need to try adding it again. Error: CordovaError: Failed to fetch plugin cordova-plugin-statusbar@2.4.3 via registry.
Probably this is either a connection problem, or plugin spec is incorrect.
Check your connection and plugin name/version/URL.
CordovaError: Error: npm: Command failed with exit code 1 Error output:
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: com.larkgames.stockmover@1.0.0
npm ERR! Found: cordova-plugin-file@4.1.1
npm ERR! node_modules/cordova-plugin-file
npm ERR! dev cordova-plugin-file@"~4.1.1" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer cordova-plugin-file@"^3.0.0" from cordova-plugin-media-capture@1.2.0
npm ERR! node_modules/cordova-plugin-media-capture
npm ERR! dev cordova-plugin-media-capture@"~1.2.0" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR! See /Users/agent04/.npm/eresolve-report.txt for a full report.

Thank you!

I’m able to reproduce the problem here. We’re working on it.

OK, still not sure why, but took it back to the Hello World config and things are now working, but can not spot any strange changes in the code, apart from a few changes in order of the code, yet was working last week, so not sure what might have changed for it to get upset…so sorry can not let others know what it was in case they have the same error.

I think I found the problem. In your config.xml, you declared several plugins multiple times.

We’ll add a check for this to our preprocessor.

The check for duplicate plugins has been added to VoltBuilder.