Volt Builder plugin support - Not building with below plugins

Hi,

Using below plugins are causing compilation error. Could you please support on this on priority. We have purchased one pro license for trail but unable to build app.

<plugin name="cordova-sqlite-storage" spec="^2.1.4" />

 <plugin name="cordova-plugin-allow-backup" spec="0.0.2">
        <variable name="BACKUP" value="false" />
    </plugin>

Regards,
Anup

What error are you seeing?

Thanks for attending this.

Error#1

UserError: Error: Plugin ‘cordova-plugin-allow-backup’ cannot be used. No longer needed. See https://github.com/macdonst/cordova-plugin-allow-backup#readme

Error#2

UserError: Failed to restore plugin “cordova-sqlite-storage”. You might need to try adding it again. Error: CordovaError: Using “requireCordovaModule” to load non-cordova module “q” is not supported. Instead, add this module to your dependencies and use regular “require” to load it.

Regards,
Anup

Error #1: cordova-plugin-allow-backup

This one is no longer needed - from the docs:

"So I totally biffed on the fact that edit-config is now supported in config.xml as well as plugin.xml so you don’t need the above plugin. All you need to do is add an edit-config section to your config.xml file like this:

<platform name="android">
    <edit-config file="AndroidManifest.xml"
                 target="/manifest/application"
                 mode="merge">
        <application android:allowBackup="false"/>
    </edit-config>
</platform>

Error #2: cordova-sqlite-storage

You’re using a very old version of this - 2.1.4. The current version is 6.0.0.

Give that a try!